p PatchFirst

CVE-2022-24858

CVE-2022-24858 · Default redirect callback vulnerable to open redirects

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

CVSS 6.1 · Moyenne · EPSS 0,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next-auth

    Versions du logiciel
    • < 3.29.2, < 4.3.2: Concernée

    Aucun correctif publié

  • next-auth npm

    Plages de versions concernées
    • SEMVER: < 3.29.2

    Mettez à jour vers 3.29.2

  • next-auth npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.3.2

    Mettez à jour vers 4.3.2

Sources originales

Vérifiez votre serveur →