CVE-2022-31008
CVE-2022-31008 · Predictable credential obfuscation seed value used in rabbitmq-server
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.
CVSS 5.5 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
rabbitmq
- Versiones
- < 3.8.32: Afectada
- >= 3.9.0, < 3.9.18: Afectada
- >= 3.10.0, < 3.10.2: Afectada
Sin corrección publicada
rabbitmq-server Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.10.8-1
Actualiza a 3.10.8-1
rabbitmq-server Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.10.8-1
Actualiza a 3.10.8-1
rabbitmq-server Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.10.8-1
Actualiza a 3.10.8-1
broker Ubuntu:22.04:LTS
- Versiones
- 1.4.0+ds1-1
- 1.4.0+ds1-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada