CVE-2022-31008
CVE-2022-31008 · Predictable credential obfuscation seed value used in rabbitmq-server
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.
CVSS 5.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
rabbitmq
- Versions
- < 3.8.32: Affected
- >= 3.9.0, < 3.9.18: Affected
- >= 3.10.0, < 3.10.2: Affected
No fix published
rabbitmq-server Debian:12
- Affected ranges
- ECOSYSTEM: < 3.10.8-1
Update to 3.10.8-1
rabbitmq-server Debian:13
- Affected ranges
- ECOSYSTEM: < 3.10.8-1
Update to 3.10.8-1
rabbitmq-server Debian:14
- Affected ranges
- ECOSYSTEM: < 3.10.8-1
Update to 3.10.8-1
broker Ubuntu:22.04:LTS
- Versions
- 1.4.0+ds1-1
- 1.4.0+ds1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published