CVE-2022-31008
CVE-2022-31008 · Predictable credential obfuscation seed value used in rabbitmq-server
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.
CVSS 5.5 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · database
Produits et versions concernés
rabbitmq
- Versions du logiciel
- < 3.8.32: Concernée
- >= 3.9.0, < 3.9.18: Concernée
- >= 3.10.0, < 3.10.2: Concernée
Aucun correctif publié
rabbitmq-server Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 3.10.8-1
Mettez à jour vers 3.10.8-1
rabbitmq-server Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.10.8-1
Mettez à jour vers 3.10.8-1
rabbitmq-server Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.10.8-1
Mettez à jour vers 3.10.8-1
broker Ubuntu:22.04:LTS
- Versions du logiciel
- 1.4.0+ds1-1
- 1.4.0+ds1-1build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié