p PatchFirst

CVE-2022-31008

CVE-2022-31008 · Predictable credential obfuscation seed value used in rabbitmq-server

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.

CVSS 5.5 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · database

Betroffene Produkte und Versionen

  • rabbitmq

    Softwareversionen
    • < 3.8.32: Betroffen
    • >= 3.9.0, < 3.9.18: Betroffen
    • >= 3.10.0, < 3.10.2: Betroffen

    Keine Korrektur veröffentlicht

  • rabbitmq-server Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.10.8-1

    Auf 3.10.8-1 aktualisieren

  • rabbitmq-server Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.10.8-1

    Auf 3.10.8-1 aktualisieren

  • rabbitmq-server Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.10.8-1

    Auf 3.10.8-1 aktualisieren

  • broker Ubuntu:22.04:LTS

    Softwareversionen
    • 1.4.0+ds1-1
    • 1.4.0+ds1-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →