p PatchFirst

CVE-2022-31186

CVE-2022-31186 · Leakage of excessive information into log in next-auth

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

CVSS 3.3 · Baja · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next-auth

    Versiones
    • >= 4.0.0, < 4.10.2: Afectada
    • < 3.29.9: Afectada

    Sin corrección publicada

  • next-auth npm

    Intervalos de versiones afectados
    • SEMVER: < 3.29.9

    Actualiza a 3.29.9

  • next-auth npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.10.2

    Actualiza a 4.10.2

Fuentes originales

Comprueba tu servidor →