p PatchFirst

CVE-2022-31186

CVE-2022-31186 · Leakage of excessive information into log in next-auth

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

CVSS 3.3 · Niedrig · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next-auth

    Softwareversionen
    • >= 4.0.0, < 4.10.2: Betroffen
    • < 3.29.9: Betroffen

    Keine Korrektur veröffentlicht

  • next-auth npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.29.9

    Auf 3.29.9 aktualisieren

  • next-auth npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.10.2

    Auf 4.10.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →