p PatchFirst

CVE-2022-31186

CVE-2022-31186 · Leakage of excessive information into log in next-auth

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

CVSS 3.3 · Low · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next-auth

    Versions
    • >= 4.0.0, < 4.10.2: Affected
    • < 3.29.9: Affected

    No fix published

  • next-auth npm

    Affected ranges
    • SEMVER: < 3.29.9

    Update to 3.29.9

  • next-auth npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 4.10.2

    Update to 4.10.2

Original sources

Check your server →