p PatchFirst

CVE-2022-31186

CVE-2022-31186 · Leakage of excessive information into log in next-auth

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

CVSS 3.3 · Faible · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next-auth

    Versions du logiciel
    • >= 4.0.0, < 4.10.2: Concernée
    • < 3.29.9: Concernée

    Aucun correctif publié

  • next-auth npm

    Plages de versions concernées
    • SEMVER: < 3.29.9

    Mettez à jour vers 3.29.9

  • next-auth npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.10.2

    Mettez à jour vers 4.10.2

Sources originales

Vérifiez votre serveur →