p PatchFirst

CVE-2022-39299

CVE-2022-39299 · Signature bypass via multiple root elements in Passport-SAML

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.

CVSS 7.4 · Alta · EPSS 4,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • passport-saml

    Versiones
    • < 3.2.2: Afectada

    Sin corrección publicada

  • passport-saml npm

    Intervalos de versiones afectados
    • SEMVER: < 3.2.2

    Actualiza a 3.2.2

  • node-saml npm

    Intervalos de versiones afectados
    • SEMVER: < 4.0.0-beta.5

    Actualiza a 4.0.0-beta.5

  • @node-saml/node-saml npm

    Intervalos de versiones afectados
    • SEMVER: < 4.0.0-beta.5

    Actualiza a 4.0.0-beta.5

  • @node-saml/passport-saml npm

    Intervalos de versiones afectados
    • SEMVER: < 4.0.0-beta.3

    Actualiza a 4.0.0-beta.3

Fuentes originales

Comprueba tu servidor →