p PatchFirst

CVE-2023-26463

CVE-2023-26463

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a variable named "public" for two different purposes within the same function. There is initially incorrect access control, later followed by an expired pointer dereference. One attack vector is sending an untrusted client certificate during EAP-TLS. A server is affected only if it loads plugins that implement TLS-based EAP methods (EAP-TLS, EAP-TTLS, EAP-PEAP, or EAP-TNC). This is fixed in 5.9.10.

CVSS 9.8 · Crítica · EPSS 2,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Desconocido

    Sin corrección publicada

  • strongswan Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.8-4

    Actualiza a 5.9.8-4

  • strongswan Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.8-4

    Actualiza a 5.9.8-4

  • strongswan Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.8-4

    Actualiza a 5.9.8-4

Fuentes originales

Comprueba tu servidor →