p PatchFirst

CVE-2023-26463

CVE-2023-26463

This page contains facts from public vulnerability sources. Check the original advisory before updating.

strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a variable named "public" for two different purposes within the same function. There is initially incorrect access control, later followed by an expired pointer dereference. One attack vector is sending an untrusted client certificate during EAP-TLS. A server is affected only if it loads plugins that implement TLS-based EAP methods (EAP-TLS, EAP-TTLS, EAP-PEAP, or EAP-TNC). This is fixed in 5.9.10.

CVSS 9.8 · Critical · EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Unknown

    No fix published

  • strongswan Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.9.8-4

    Update to 5.9.8-4

  • strongswan Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.9.8-4

    Update to 5.9.8-4

  • strongswan Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.9.8-4

    Update to 5.9.8-4

Original sources

Check your server →