p PatchFirst

CVE-2023-26463

CVE-2023-26463

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a variable named "public" for two different purposes within the same function. There is initially incorrect access control, later followed by an expired pointer dereference. One attack vector is sending an untrusted client certificate during EAP-TLS. A server is affected only if it loads plugins that implement TLS-based EAP methods (EAP-TLS, EAP-TTLS, EAP-PEAP, or EAP-TNC). This is fixed in 5.9.10.

CVSS 9.8 · Critique · EPSS 2,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Inconnu

    Aucun correctif publié

  • strongswan Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 5.9.8-4

    Mettez à jour vers 5.9.8-4

  • strongswan Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 5.9.8-4

    Mettez à jour vers 5.9.8-4

  • strongswan Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 5.9.8-4

    Mettez à jour vers 5.9.8-4

Sources originales

Vérifiez votre serveur →