p PatchFirst

CVE-2024-27298

CVE-2024-27298 · Parse Server literalizeRegexPart SQL Injection

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

CVSS 10.0 · Crítica · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • parse-server

    Versiones
    • < 6.5.0: Afectada
    • >= 7.0.0-alpha.1, < 7.0.0-alpha.20: Afectada

    Sin corrección publicada

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: < 6.5.0

    Actualiza a 6.5.0

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 7.0.0-alpha.1, < 7.0.0-alpha.20

    Actualiza a 7.0.0-alpha.20

Fuentes originales

Comprueba tu servidor →