p PatchFirst

CVE-2024-27298

CVE-2024-27298 · Parse Server literalizeRegexPart SQL Injection

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

CVSS 10.0 · Kritisch · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • parse-server

    Softwareversionen
    • < 6.5.0: Betroffen
    • >= 7.0.0-alpha.1, < 7.0.0-alpha.20: Betroffen

    Keine Korrektur veröffentlicht

  • parse-server npm

    Betroffene Versionsbereiche
    • SEMVER: < 6.5.0

    Auf 6.5.0 aktualisieren

  • parse-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0-alpha.1, < 7.0.0-alpha.20

    Auf 7.0.0-alpha.20 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →