p PatchFirst

CVE-2024-27298

CVE-2024-27298 · Parse Server literalizeRegexPart SQL Injection

This page contains facts from public vulnerability sources. Check the original advisory before updating.

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

CVSS 10.0 · Critical · EPSS 1.0% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • parse-server

    Versions
    • < 6.5.0: Affected
    • >= 7.0.0-alpha.1, < 7.0.0-alpha.20: Affected

    No fix published

  • parse-server npm

    Affected ranges
    • SEMVER: < 6.5.0

    Update to 6.5.0

  • parse-server npm

    Affected ranges
    • SEMVER: ≥ 7.0.0-alpha.1, < 7.0.0-alpha.20

    Update to 7.0.0-alpha.20

Original sources

Check your server →