p PatchFirst

CVE-2024-27298

CVE-2024-27298 · Parse Server literalizeRegexPart SQL Injection

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

CVSS 10.0 · Critique · EPSS 1,0% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • parse-server

    Versions du logiciel
    • < 6.5.0: Concernée
    • >= 7.0.0-alpha.1, < 7.0.0-alpha.20: Concernée

    Aucun correctif publié

  • parse-server npm

    Plages de versions concernées
    • SEMVER: < 6.5.0

    Mettez à jour vers 6.5.0

  • parse-server npm

    Plages de versions concernées
    • SEMVER: ≥ 7.0.0-alpha.1, < 7.0.0-alpha.20

    Mettez à jour vers 7.0.0-alpha.20

Sources originales

Vérifiez votre serveur →