p PatchFirst

CVE-2024-32077

CVE-2024-32077 · Apache Airflow: XSS vulnerability in Task Instance Log/Log Details

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

CVSS 5.4 · Media · EPSS 1,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache airflow

    Versiones
    • ≥ 2.9.0, < 2.9.1: Afectada (semver)

    Actualiza a 2.9.1

  • apache-airflow PyPI

    Versiones
    • 2.9.0
    • 2.9.1rc1
    • 2.9.1rc2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.9.0, < 2.9.1

    Actualiza a 2.9.1

  • apache-airflow PyPI

    Versiones
    • 2.9.0b1
    • 2.9.0b2
    • 2.9.0rc1
    • 2.9.0rc2
    • 2.9.0rc3
    Intervalos de versiones afectados
    • {"events": [{"introduced": "0"}, {"last_affected": "2.9.0-NA"}, {"last_affected": "2.9.0-beta1"}, {"last_affected": "2.9.0-beta2"}, {"last_affected": "2.9.0-rc1"}, {"last_affected": "2.9.0-rc2"}, {"last_affected": "2.9.0-rc3"}], "type": "ECOSYSTEM"}

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →