p PatchFirst

CVE-2024-32077

CVE-2024-32077 · Apache Airflow: XSS vulnerability in Task Instance Log/Log Details

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

CVSS 5.4 · Mittel · EPSS 1,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • apache airflow

    Softwareversionen
    • ≥ 2.9.0, < 2.9.1: Betroffen (semver)

    Auf 2.9.1 aktualisieren

  • apache-airflow PyPI

    Softwareversionen
    • 2.9.0
    • 2.9.1rc1
    • 2.9.1rc2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.9.0, < 2.9.1

    Auf 2.9.1 aktualisieren

  • apache-airflow PyPI

    Softwareversionen
    • 2.9.0b1
    • 2.9.0b2
    • 2.9.0rc1
    • 2.9.0rc2
    • 2.9.0rc3
    Betroffene Versionsbereiche
    • {"events": [{"introduced": "0"}, {"last_affected": "2.9.0-NA"}, {"last_affected": "2.9.0-beta1"}, {"last_affected": "2.9.0-beta2"}, {"last_affected": "2.9.0-rc1"}, {"last_affected": "2.9.0-rc2"}, {"last_affected": "2.9.0-rc3"}], "type": "ECOSYSTEM"}

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →