CVE-2024-32077
CVE-2024-32077 · Apache Airflow: XSS vulnerability in Task Instance Log/Log Details
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. Users are recommended to upgrade to version 2.9.1, which fixes this issue.
CVSS 5.4 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- ≥ 2.9.0, < 2.9.1: Affected (semver)
Update to 2.9.1
apache-airflow PyPI
- Versions
- 2.9.0
- 2.9.1rc1
- 2.9.1rc2
- Affected ranges
- ECOSYSTEM: ≥ 2.9.0, < 2.9.1
Update to 2.9.1
apache-airflow PyPI
- Versions
- 2.9.0b1
- 2.9.0b2
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- Affected ranges
- {"events": [{"introduced": "0"}, {"last_affected": "2.9.0-NA"}, {"last_affected": "2.9.0-beta1"}, {"last_affected": "2.9.0-beta2"}, {"last_affected": "2.9.0-rc1"}, {"last_affected": "2.9.0-rc2"}, {"last_affected": "2.9.0-rc3"}], "type": "ECOSYSTEM"}
No fix published