CVE-2024-32077
CVE-2024-32077 · Apache Airflow: XSS vulnerability in Task Instance Log/Log Details
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. Users are recommended to upgrade to version 2.9.1, which fixes this issue.
CVSS 5.4 · Moyenne · EPSS 1,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
apache airflow
- Versions du logiciel
- ≥ 2.9.0, < 2.9.1: Concernée (semver)
Mettez à jour vers 2.9.1
apache-airflow PyPI
- Versions du logiciel
- 2.9.0
- 2.9.1rc1
- 2.9.1rc2
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.9.0, < 2.9.1
Mettez à jour vers 2.9.1
apache-airflow PyPI
- Versions du logiciel
- 2.9.0b1
- 2.9.0b2
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- Plages de versions concernées
- {"events": [{"introduced": "0"}, {"last_affected": "2.9.0-NA"}, {"last_affected": "2.9.0-beta1"}, {"last_affected": "2.9.0-beta2"}, {"last_affected": "2.9.0-rc1"}, {"last_affected": "2.9.0-rc2"}, {"last_affected": "2.9.0-rc3"}], "type": "ECOSYSTEM"}
Aucun correctif publié