p PatchFirst

CVE-2024-48514

CVE-2024-48514

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.

CVSS 9.8 · Crítica · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • maestroerror/php-heic-to-jpg Packagist

    Versiones
    • v0.1
    • v0.2
    • v0.3
    • v0.3.1
    • v0.3.2
    • v0.4.0
    • v1.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.0.5

    Actualiza a 1.0.5

Fuentes originales

Comprueba tu servidor →