p PatchFirst

CVE-2024-48514

CVE-2024-48514

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.

CVSS 9.8 · Kritisch · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • maestroerror/php-heic-to-jpg Packagist

    Softwareversionen
    • v0.1
    • v0.2
    • v0.3
    • v0.3.1
    • v0.3.2
    • v0.4.0
    • v1.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.5

    Auf 1.0.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →