CVE-2024-48514
CVE-2024-48514
This page contains facts from public vulnerability sources. Check the original advisory before updating.
php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.
CVSS 9.8 · Critical · EPSS 1.0% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
maestroerror/php-heic-to-jpg Packagist
- Versions
- v0.1
- v0.2
- v0.3
- v0.3.1
- v0.3.2
- v0.4.0
- v1.0
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- Affected ranges
- ECOSYSTEM: < 1.0.5
Update to 1.0.5