p PatchFirst

CVE-2024-53847

CVE-2024-53847 · Trix vulnerable to Cross-site Scripting on copy & paste

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

CVSS 5.1 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • trix

    Versiones
    • >= 2.0.0, < 2.1.9: Afectada
    • >= 1.0.0, < 1.3.3: Afectada

    Sin corrección publicada

  • trix npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0, < 2.1.9

    Actualiza a 2.1.9

  • trix npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.0.0, < 1.3.3

    Actualiza a 1.3.3

Fuentes originales

Comprueba tu servidor →