p PatchFirst

CVE-2024-53847

CVE-2024-53847 · Trix vulnerable to Cross-site Scripting on copy & paste

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

CVSS 5.1 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • trix

    Versions
    • >= 2.0.0, < 2.1.9: Affected
    • >= 1.0.0, < 1.3.3: Affected

    No fix published

  • trix npm

    Affected ranges
    • SEMVER: ≥ 2.0.0, < 2.1.9

    Update to 2.1.9

  • trix npm

    Affected ranges
    • SEMVER: ≥ 1.0.0, < 1.3.3

    Update to 1.3.3

Original sources

Check your server →