p PatchFirst

CVE-2024-53847

CVE-2024-53847 · Trix vulnerable to Cross-site Scripting on copy & paste

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

CVSS 5.1 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • trix

    Softwareversionen
    • >= 2.0.0, < 2.1.9: Betroffen
    • >= 1.0.0, < 1.3.3: Betroffen

    Keine Korrektur veröffentlicht

  • trix npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.1.9

    Auf 2.1.9 aktualisieren

  • trix npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.0.0, < 1.3.3

    Auf 1.3.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →