p PatchFirst

CVE-2024-53847

CVE-2024-53847 · Trix vulnerable to Cross-site Scripting on copy & paste

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

CVSS 5.1 · Moyenne · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • trix

    Versions du logiciel
    • >= 2.0.0, < 2.1.9: Concernée
    • >= 1.0.0, < 1.3.3: Concernée

    Aucun correctif publié

  • trix npm

    Plages de versions concernées
    • SEMVER: ≥ 2.0.0, < 2.1.9

    Mettez à jour vers 2.1.9

  • trix npm

    Plages de versions concernées
    • SEMVER: ≥ 1.0.0, < 1.3.3

    Mettez à jour vers 1.3.3

Sources originales

Vérifiez votre serveur →