CVE-2024-56201
CVE-2024-56201 · Jinja has a sandbox breakout through malicious filenames
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
CVSS 5.4 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
jinja
- Versiones
- >= 3.0.0, < 3.1.5: Afectada
Sin corrección publicada
jinja2 Debian:12
- Versiones
- 3.1.2-1
- 3.1.2-1+deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.2-1+deb12u2
Actualiza a 3.1.2-1+deb12u2
jinja2 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.5-1
Actualiza a 3.1.5-1
jinja2 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.5-1
Actualiza a 3.1.5-1
jinja2 PyPI
- Versiones
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.0.0, < 3.1.5
Actualiza a 3.1.5
jinja2 Ubuntu:Pro:14.04:LTS
- Versiones
- 2.7-3
- 2.7.1-1
- 2.7.2-1
- 2.7.2-2
- 2.7.2-2ubuntu0.1~esm1
- 2.7.2-2ubuntu0.1~esm2
- 2.7.2-2ubuntu0.1~esm3
- 2.7.2-2ubuntu0.1~esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.2-2ubuntu0.1~esm6
Actualiza a 2.7.2-2ubuntu0.1~esm6
jinja2 Ubuntu:Pro:16.04:LTS
- Versiones
- 2.8-1
- 2.8-1ubuntu0.1
- 2.8-1ubuntu0.1+esm1
- 2.8-1ubuntu0.1+esm2
- 2.8-1ubuntu0.1+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.8-1ubuntu0.1+esm5
Actualiza a 2.8-1ubuntu0.1+esm5
jinja2 Ubuntu:Pro:18.04:LTS
- Versiones
- 2.9.6-1
- 2.10-1
- 2.10-1ubuntu0.18.04.1
- 2.10-1ubuntu0.18.04.1+esm1
- 2.10-1ubuntu0.18.04.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.10-1ubuntu0.18.04.1+esm3
Actualiza a 2.10-1ubuntu0.18.04.1+esm3
jinja2 Ubuntu:20.04:LTS
- Versiones
- 2.10-2ubuntu1
- 2.10-2ubuntu2
- 2.10.1-1ubuntu1
- 2.10.1-2
- 2.10.1-2ubuntu0.2
- 2.10.1-2ubuntu0.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.10.1-2ubuntu0.4
Actualiza a 2.10.1-2ubuntu0.4
jinja2 Ubuntu:22.04:LTS
- Versiones
- 2.11.3-1
- 3.0.1-2
- 3.0.3-1
- 3.0.3-1ubuntu0.1
- 3.0.3-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.3-1ubuntu0.3
Actualiza a 3.0.3-1ubuntu0.3
jinja2 Ubuntu:24.04:LTS
- Versiones
- 3.1.2-1
- 3.1.2-1ubuntu1
- 3.1.2-1ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.2-1ubuntu1.2
Actualiza a 3.1.2-1ubuntu1.2