CVE-2024-56201
CVE-2024-56201 · Jinja has a sandbox breakout through malicious filenames
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
CVSS 5.4 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
jinja
- Softwareversionen
- >= 3.0.0, < 3.1.5: Betroffen
Keine Korrektur veröffentlicht
jinja2 Debian:12
- Softwareversionen
- 3.1.2-1
- 3.1.2-1+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.2-1+deb12u2
Auf 3.1.2-1+deb12u2 aktualisieren
jinja2 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.5-1
Auf 3.1.5-1 aktualisieren
jinja2 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.5-1
Auf 3.1.5-1 aktualisieren
jinja2 PyPI
- Softwareversionen
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.0.0, < 3.1.5
Auf 3.1.5 aktualisieren
jinja2 Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 2.7-3
- 2.7.1-1
- 2.7.2-1
- 2.7.2-2
- 2.7.2-2ubuntu0.1~esm1
- 2.7.2-2ubuntu0.1~esm2
- 2.7.2-2ubuntu0.1~esm3
- 2.7.2-2ubuntu0.1~esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.2-2ubuntu0.1~esm6
Auf 2.7.2-2ubuntu0.1~esm6 aktualisieren
jinja2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.8-1
- 2.8-1ubuntu0.1
- 2.8-1ubuntu0.1+esm1
- 2.8-1ubuntu0.1+esm2
- 2.8-1ubuntu0.1+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.8-1ubuntu0.1+esm5
Auf 2.8-1ubuntu0.1+esm5 aktualisieren
jinja2 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.9.6-1
- 2.10-1
- 2.10-1ubuntu0.18.04.1
- 2.10-1ubuntu0.18.04.1+esm1
- 2.10-1ubuntu0.18.04.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10-1ubuntu0.18.04.1+esm3
Auf 2.10-1ubuntu0.18.04.1+esm3 aktualisieren
jinja2 Ubuntu:20.04:LTS
- Softwareversionen
- 2.10-2ubuntu1
- 2.10-2ubuntu2
- 2.10.1-1ubuntu1
- 2.10.1-2
- 2.10.1-2ubuntu0.2
- 2.10.1-2ubuntu0.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10.1-2ubuntu0.4
Auf 2.10.1-2ubuntu0.4 aktualisieren
jinja2 Ubuntu:22.04:LTS
- Softwareversionen
- 2.11.3-1
- 3.0.1-2
- 3.0.3-1
- 3.0.3-1ubuntu0.1
- 3.0.3-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.3-1ubuntu0.3
Auf 3.0.3-1ubuntu0.3 aktualisieren
jinja2 Ubuntu:24.04:LTS
- Softwareversionen
- 3.1.2-1
- 3.1.2-1ubuntu1
- 3.1.2-1ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.2-1ubuntu1.2
Auf 3.1.2-1ubuntu1.2 aktualisieren