CVE-2024-56201
CVE-2024-56201 · Jinja has a sandbox breakout through malicious filenames
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
CVSS 5.4 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
jinja
- Versions du logiciel
- >= 3.0.0, < 3.1.5: Concernée
Aucun correctif publié
jinja2 Debian:12
- Versions du logiciel
- 3.1.2-1
- 3.1.2-1+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 3.1.2-1+deb12u2
Mettez à jour vers 3.1.2-1+deb12u2
jinja2 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.1.5-1
Mettez à jour vers 3.1.5-1
jinja2 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.1.5-1
Mettez à jour vers 3.1.5-1
jinja2 PyPI
- Versions du logiciel
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.1.5
Mettez à jour vers 3.1.5
jinja2 Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 2.7-3
- 2.7.1-1
- 2.7.2-1
- 2.7.2-2
- 2.7.2-2ubuntu0.1~esm1
- 2.7.2-2ubuntu0.1~esm2
- 2.7.2-2ubuntu0.1~esm3
- 2.7.2-2ubuntu0.1~esm4
- Plages de versions concernées
- ECOSYSTEM: < 2.7.2-2ubuntu0.1~esm6
Mettez à jour vers 2.7.2-2ubuntu0.1~esm6
jinja2 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2.8-1
- 2.8-1ubuntu0.1
- 2.8-1ubuntu0.1+esm1
- 2.8-1ubuntu0.1+esm2
- 2.8-1ubuntu0.1+esm3
- Plages de versions concernées
- ECOSYSTEM: < 2.8-1ubuntu0.1+esm5
Mettez à jour vers 2.8-1ubuntu0.1+esm5
jinja2 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 2.9.6-1
- 2.10-1
- 2.10-1ubuntu0.18.04.1
- 2.10-1ubuntu0.18.04.1+esm1
- 2.10-1ubuntu0.18.04.1+esm2
- Plages de versions concernées
- ECOSYSTEM: < 2.10-1ubuntu0.18.04.1+esm3
Mettez à jour vers 2.10-1ubuntu0.18.04.1+esm3
jinja2 Ubuntu:20.04:LTS
- Versions du logiciel
- 2.10-2ubuntu1
- 2.10-2ubuntu2
- 2.10.1-1ubuntu1
- 2.10.1-2
- 2.10.1-2ubuntu0.2
- 2.10.1-2ubuntu0.3
- Plages de versions concernées
- ECOSYSTEM: < 2.10.1-2ubuntu0.4
Mettez à jour vers 2.10.1-2ubuntu0.4
jinja2 Ubuntu:22.04:LTS
- Versions du logiciel
- 2.11.3-1
- 3.0.1-2
- 3.0.3-1
- 3.0.3-1ubuntu0.1
- 3.0.3-1ubuntu0.2
- Plages de versions concernées
- ECOSYSTEM: < 3.0.3-1ubuntu0.3
Mettez à jour vers 3.0.3-1ubuntu0.3
jinja2 Ubuntu:24.04:LTS
- Versions du logiciel
- 3.1.2-1
- 3.1.2-1ubuntu1
- 3.1.2-1ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: < 3.1.2-1ubuntu1.2
Mettez à jour vers 3.1.2-1ubuntu1.2