CVE-2024-56201
CVE-2024-56201 · Jinja has a sandbox breakout through malicious filenames
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
CVSS 5.4 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
jinja
- Versions
- >= 3.0.0, < 3.1.5: Affected
No fix published
jinja2 Debian:12
- Versions
- 3.1.2-1
- 3.1.2-1+deb12u1
- Affected ranges
- ECOSYSTEM: < 3.1.2-1+deb12u2
Update to 3.1.2-1+deb12u2
jinja2 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.5-1
Update to 3.1.5-1
jinja2 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.5-1
Update to 3.1.5-1
jinja2 PyPI
- Versions
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0, < 3.1.5
Update to 3.1.5
jinja2 Ubuntu:Pro:14.04:LTS
- Versions
- 2.7-3
- 2.7.1-1
- 2.7.2-1
- 2.7.2-2
- 2.7.2-2ubuntu0.1~esm1
- 2.7.2-2ubuntu0.1~esm2
- 2.7.2-2ubuntu0.1~esm3
- 2.7.2-2ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: < 2.7.2-2ubuntu0.1~esm6
Update to 2.7.2-2ubuntu0.1~esm6
jinja2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.8-1
- 2.8-1ubuntu0.1
- 2.8-1ubuntu0.1+esm1
- 2.8-1ubuntu0.1+esm2
- 2.8-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: < 2.8-1ubuntu0.1+esm5
Update to 2.8-1ubuntu0.1+esm5
jinja2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.9.6-1
- 2.10-1
- 2.10-1ubuntu0.18.04.1
- 2.10-1ubuntu0.18.04.1+esm1
- 2.10-1ubuntu0.18.04.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.10-1ubuntu0.18.04.1+esm3
Update to 2.10-1ubuntu0.18.04.1+esm3
jinja2 Ubuntu:20.04:LTS
- Versions
- 2.10-2ubuntu1
- 2.10-2ubuntu2
- 2.10.1-1ubuntu1
- 2.10.1-2
- 2.10.1-2ubuntu0.2
- 2.10.1-2ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 2.10.1-2ubuntu0.4
Update to 2.10.1-2ubuntu0.4
jinja2 Ubuntu:22.04:LTS
- Versions
- 2.11.3-1
- 3.0.1-2
- 3.0.3-1
- 3.0.3-1ubuntu0.1
- 3.0.3-1ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 3.0.3-1ubuntu0.3
Update to 3.0.3-1ubuntu0.3
jinja2 Ubuntu:24.04:LTS
- Versions
- 3.1.2-1
- 3.1.2-1ubuntu1
- 3.1.2-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 3.1.2-1ubuntu1.2
Update to 3.1.2-1ubuntu1.2