p PatchFirst

CVE-2025-32442

CVE-2025-32442 · Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.

CVSS 7.5 · Alta · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • fastify

    Versiones
    • >= 5.0.0, < 5.3.2: Afectada
    • = 4.29.0: Afectada

    Sin corrección publicada

  • fastify npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 5.3.2, < 5.8.5

    Actualiza a 5.8.5

  • fastify npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 5.0.0, < 5.3.2

    Actualiza a 5.3.2

  • fastify npm

    Versiones
    • 4.29.0
    Intervalos de versiones afectados
    • SEMVER: ≥ 4.29.0, < 4.29.1

    Actualiza a 4.29.1

Fuentes originales

Comprueba tu servidor →