CVE-2025-32442
CVE-2025-32442 · Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.
CVSS 7.5 · Hoch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
fastify
- Softwareversionen
- >= 5.0.0, < 5.3.2: Betroffen
- = 4.29.0: Betroffen
Keine Korrektur veröffentlicht
fastify npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 5.3.2, < 5.8.5
Auf 5.8.5 aktualisieren
fastify npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 5.0.0, < 5.3.2
Auf 5.3.2 aktualisieren
fastify npm
- Softwareversionen
- 4.29.0
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.29.0, < 4.29.1
Auf 4.29.1 aktualisieren
Originalquellen
- https://github.com/fastify/fastify/security/advisories/GHSA-mg2h-6x62-wpwc
- https://github.com/fastify/fastify/commit/436da4c06dfbbb8c24adee3a64de0c51e4f47418
- https://github.com/fastify/fastify/commit/f3d2bcb3963cd570a582e5d39aab01a9ae692fe4
- https://hackerone.com/reports/3087928
- https://nvd.nist.gov/vuln/detail/CVE-2025-32442