p PatchFirst

CVE-2025-32442

CVE-2025-32442 · Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.

CVSS 7.5 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • fastify

    Versions
    • >= 5.0.0, < 5.3.2: Affected
    • = 4.29.0: Affected

    No fix published

  • fastify npm

    Affected ranges
    • SEMVER: ≥ 5.3.2, < 5.8.5

    Update to 5.8.5

  • fastify npm

    Affected ranges
    • SEMVER: ≥ 5.0.0, < 5.3.2

    Update to 5.3.2

  • fastify npm

    Versions
    • 4.29.0
    Affected ranges
    • SEMVER: ≥ 4.29.0, < 4.29.1

    Update to 4.29.1

Original sources

Check your server →