CVE-2025-32442
CVE-2025-32442 · Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.
CVSS 7.5 · Élevée · EPSS 0,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
fastify
- Versions du logiciel
- >= 5.0.0, < 5.3.2: Concernée
- = 4.29.0: Concernée
Aucun correctif publié
fastify npm
- Plages de versions concernées
- SEMVER: ≥ 5.3.2, < 5.8.5
Mettez à jour vers 5.8.5
fastify npm
- Plages de versions concernées
- SEMVER: ≥ 5.0.0, < 5.3.2
Mettez à jour vers 5.3.2
fastify npm
- Versions du logiciel
- 4.29.0
- Plages de versions concernées
- SEMVER: ≥ 4.29.0, < 4.29.1
Mettez à jour vers 4.29.1
Sources originales
- https://github.com/fastify/fastify/security/advisories/GHSA-mg2h-6x62-wpwc
- https://github.com/fastify/fastify/commit/436da4c06dfbbb8c24adee3a64de0c51e4f47418
- https://github.com/fastify/fastify/commit/f3d2bcb3963cd570a582e5d39aab01a9ae692fe4
- https://hackerone.com/reports/3087928
- https://nvd.nist.gov/vuln/detail/CVE-2025-32442