CVE-2025-54888
CVE-2025-54888 · @fedify/fedify: Improper Authentication and Incorrect Authorization
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Fedify is a TypeScript library for building federated server apps powered by ActivityPub. In versions below 1.3.20, 1.4.0-dev.585 through 1.4.12, 1.5.0-dev.636 through 1.5.4, 1.6.0-dev.754 through 1.6.7, 1.7.0-pr.251.885 through 1.7.8 and 1.8.0-dev.909 through 1.8.4, an authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances. This is fixed in versions 1.3.20, 1.4.13, 1.5.5, 1.6.8, 1.7.9 and 1.8.5.
CVSS 8.7 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
fedify
- Versiones
- < 1.3.20: Afectada
- >= 1.4.0-dev.585, < 1.4.13: Afectada
- >= 1.5.0-dev.636, < 1.5.5: Afectada
- >= 1.6.0-dev.754, < 1.6.8: Afectada
- >= 1.7.0-pr.251.885, < 1.7.9: Afectada
- >= 1.8.0-dev.909, < 1.8.5: Afectada
Sin corrección publicada
@fedify/fedify npm
- Intervalos de versiones afectados
- SEMVER: < 1.3.20
Actualiza a 1.3.20
@fedify/fedify npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.4.0-dev.585, < 1.4.13
Actualiza a 1.4.13
@fedify/fedify npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.5.0-dev.636, < 1.5.5
Actualiza a 1.5.5
@fedify/fedify npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.6.0-dev.754, < 1.6.8
Actualiza a 1.6.8
@fedify/fedify npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.7.0-pr.251.885, < 1.7.9
Actualiza a 1.7.9
@fedify/fedify npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.8.0-dev.909, < 1.8.5
Actualiza a 1.8.5