p PatchFirst

CVE-2025-54888

CVE-2025-54888 · @fedify/fedify: Improper Authentication and Incorrect Authorization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. In versions below 1.3.20, 1.4.0-dev.585 through 1.4.12, 1.5.0-dev.636 through 1.5.4, 1.6.0-dev.754 through 1.6.7, 1.7.0-pr.251.885 through 1.7.8 and 1.8.0-dev.909 through 1.8.4, an authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances. This is fixed in versions 1.3.20, 1.4.13, 1.5.5, 1.6.8, 1.7.9 and 1.8.5.

CVSS 8.7 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • fedify

    Softwareversionen
    • < 1.3.20: Betroffen
    • >= 1.4.0-dev.585, < 1.4.13: Betroffen
    • >= 1.5.0-dev.636, < 1.5.5: Betroffen
    • >= 1.6.0-dev.754, < 1.6.8: Betroffen
    • >= 1.7.0-pr.251.885, < 1.7.9: Betroffen
    • >= 1.8.0-dev.909, < 1.8.5: Betroffen

    Keine Korrektur veröffentlicht

  • @fedify/fedify npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.3.20

    Auf 1.3.20 aktualisieren

  • @fedify/fedify npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.4.0-dev.585, < 1.4.13

    Auf 1.4.13 aktualisieren

  • @fedify/fedify npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.5.0-dev.636, < 1.5.5

    Auf 1.5.5 aktualisieren

  • @fedify/fedify npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.6.0-dev.754, < 1.6.8

    Auf 1.6.8 aktualisieren

  • @fedify/fedify npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.7.0-pr.251.885, < 1.7.9

    Auf 1.7.9 aktualisieren

  • @fedify/fedify npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.8.0-dev.909, < 1.8.5

    Auf 1.8.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →