CVE-2025-54888
CVE-2025-54888 · @fedify/fedify: Improper Authentication and Incorrect Authorization
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Fedify is a TypeScript library for building federated server apps powered by ActivityPub. In versions below 1.3.20, 1.4.0-dev.585 through 1.4.12, 1.5.0-dev.636 through 1.5.4, 1.6.0-dev.754 through 1.6.7, 1.7.0-pr.251.885 through 1.7.8 and 1.8.0-dev.909 through 1.8.4, an authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances. This is fixed in versions 1.3.20, 1.4.13, 1.5.5, 1.6.8, 1.7.9 and 1.8.5.
CVSS 8.7 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
fedify
- Versions
- < 1.3.20: Affected
- >= 1.4.0-dev.585, < 1.4.13: Affected
- >= 1.5.0-dev.636, < 1.5.5: Affected
- >= 1.6.0-dev.754, < 1.6.8: Affected
- >= 1.7.0-pr.251.885, < 1.7.9: Affected
- >= 1.8.0-dev.909, < 1.8.5: Affected
No fix published
@fedify/fedify npm
- Affected ranges
- SEMVER: < 1.3.20
Update to 1.3.20
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 1.4.0-dev.585, < 1.4.13
Update to 1.4.13
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 1.5.0-dev.636, < 1.5.5
Update to 1.5.5
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 1.6.0-dev.754, < 1.6.8
Update to 1.6.8
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 1.7.0-pr.251.885, < 1.7.9
Update to 1.7.9
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 1.8.0-dev.909, < 1.8.5
Update to 1.8.5