CVE-2025-54888
CVE-2025-54888 · @fedify/fedify: Improper Authentication and Incorrect Authorization
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Fedify is a TypeScript library for building federated server apps powered by ActivityPub. In versions below 1.3.20, 1.4.0-dev.585 through 1.4.12, 1.5.0-dev.636 through 1.5.4, 1.6.0-dev.754 through 1.6.7, 1.7.0-pr.251.885 through 1.7.8 and 1.8.0-dev.909 through 1.8.4, an authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances. This is fixed in versions 1.3.20, 1.4.13, 1.5.5, 1.6.8, 1.7.9 and 1.8.5.
CVSS 8.7 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
fedify
- Versions du logiciel
- < 1.3.20: Concernée
- >= 1.4.0-dev.585, < 1.4.13: Concernée
- >= 1.5.0-dev.636, < 1.5.5: Concernée
- >= 1.6.0-dev.754, < 1.6.8: Concernée
- >= 1.7.0-pr.251.885, < 1.7.9: Concernée
- >= 1.8.0-dev.909, < 1.8.5: Concernée
Aucun correctif publié
@fedify/fedify npm
- Plages de versions concernées
- SEMVER: < 1.3.20
Mettez à jour vers 1.3.20
@fedify/fedify npm
- Plages de versions concernées
- SEMVER: ≥ 1.4.0-dev.585, < 1.4.13
Mettez à jour vers 1.4.13
@fedify/fedify npm
- Plages de versions concernées
- SEMVER: ≥ 1.5.0-dev.636, < 1.5.5
Mettez à jour vers 1.5.5
@fedify/fedify npm
- Plages de versions concernées
- SEMVER: ≥ 1.6.0-dev.754, < 1.6.8
Mettez à jour vers 1.6.8
@fedify/fedify npm
- Plages de versions concernées
- SEMVER: ≥ 1.7.0-pr.251.885, < 1.7.9
Mettez à jour vers 1.7.9
@fedify/fedify npm
- Plages de versions concernées
- SEMVER: ≥ 1.8.0-dev.909, < 1.8.5
Mettez à jour vers 1.8.5