p PatchFirst

CVE-2025-5889

CVE-2025-5889 · juliangruber brace-expansion index.js expand redos

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS 2.3 · Baja · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • brace-expansion

    Versiones
    • 1.1.0: Afectada
    • 1.1.1: Afectada
    • 1.1.2: Afectada
    • 1.1.3: Afectada
    • 1.1.4: Afectada
    • 1.1.5: Afectada
    • 1.1.6: Afectada
    • 1.1.7: Afectada
    • 1.1.8: Afectada
    • 1.1.9: Afectada
    • 1.1.10: Afectada
    • 1.1.11: Afectada
    • 2.0.0: Afectada
    • 2.0.1: Afectada
    • 3.0: Afectada
    • 4.0: Afectada
    • 1.1.12: No afectada
    • 2.0.2: No afectada
    • 3.0.1: No afectada
    • 4.0.1: No afectada

    Actualiza a 1.1.12; Actualiza a 2.0.2; Actualiza a 3.0.1; Actualiza a 4.0.1

  • node-brace-expansion Debian:12

    Versiones
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.0.1+~1.1.0-2

    Actualiza a 2.0.1+~1.1.0-2

  • node-brace-expansion Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.0.1+~1.1.0-2

    Actualiza a 2.0.1+~1.1.0-2

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0, < 2.0.2

    Actualiza a 2.0.2

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.0.0, < 1.1.12

    Actualiza a 1.1.12

  • brace-expansion npm

    Versiones
    • 3.0.0
    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.0.1

    Actualiza a 3.0.1

  • brace-expansion npm

    Versiones
    • 4.0.0
    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.0.1

    Actualiza a 4.0.1

  • node-brace-expansion Ubuntu:18.04:LTS

    Versiones
    • 1.1.8-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:20.04:LTS

    Versiones
    • 1.1.8-1
    • 1.1.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:22.04:LTS

    Versiones
    • 2.0.0-1
    • 2.0.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:24.04:LTS

    Versiones
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:25.10

    Versiones
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →