p PatchFirst

CVE-2025-5889

CVE-2025-5889 · juliangruber brace-expansion index.js expand redos

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS 2.3 · Faible · EPSS 0,6% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • brace-expansion

    Versions du logiciel
    • 1.1.0: Concernée
    • 1.1.1: Concernée
    • 1.1.2: Concernée
    • 1.1.3: Concernée
    • 1.1.4: Concernée
    • 1.1.5: Concernée
    • 1.1.6: Concernée
    • 1.1.7: Concernée
    • 1.1.8: Concernée
    • 1.1.9: Concernée
    • 1.1.10: Concernée
    • 1.1.11: Concernée
    • 2.0.0: Concernée
    • 2.0.1: Concernée
    • 3.0: Concernée
    • 4.0: Concernée
    • 1.1.12: Non concernée
    • 2.0.2: Non concernée
    • 3.0.1: Non concernée
    • 4.0.1: Non concernée

    Mettez à jour vers 1.1.12; Mettez à jour vers 2.0.2; Mettez à jour vers 3.0.1; Mettez à jour vers 4.0.1

  • node-brace-expansion Debian:12

    Versions du logiciel
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-brace-expansion Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 2.0.1+~1.1.0-2

    Mettez à jour vers 2.0.1+~1.1.0-2

  • node-brace-expansion Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 2.0.1+~1.1.0-2

    Mettez à jour vers 2.0.1+~1.1.0-2

  • brace-expansion npm

    Plages de versions concernées
    • SEMVER: ≥ 2.0.0, < 2.0.2

    Mettez à jour vers 2.0.2

  • brace-expansion npm

    Plages de versions concernées
    • SEMVER: ≥ 1.0.0, < 1.1.12

    Mettez à jour vers 1.1.12

  • brace-expansion npm

    Versions du logiciel
    • 3.0.0
    Plages de versions concernées
    • SEMVER: ≥ 3.0.0, < 3.0.1

    Mettez à jour vers 3.0.1

  • brace-expansion npm

    Versions du logiciel
    • 4.0.0
    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.0.1

    Mettez à jour vers 4.0.1

  • node-brace-expansion Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.1.8-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-brace-expansion Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.1.8-1
    • 1.1.11-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-brace-expansion Ubuntu:22.04:LTS

    Versions du logiciel
    • 2.0.0-1
    • 2.0.1-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-brace-expansion Ubuntu:24.04:LTS

    Versions du logiciel
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-brace-expansion Ubuntu:25.10

    Versions du logiciel
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →