p PatchFirst

CVE-2025-5889

CVE-2025-5889 · juliangruber brace-expansion index.js expand redos

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS 2.3 · Niedrig · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • brace-expansion

    Softwareversionen
    • 1.1.0: Betroffen
    • 1.1.1: Betroffen
    • 1.1.2: Betroffen
    • 1.1.3: Betroffen
    • 1.1.4: Betroffen
    • 1.1.5: Betroffen
    • 1.1.6: Betroffen
    • 1.1.7: Betroffen
    • 1.1.8: Betroffen
    • 1.1.9: Betroffen
    • 1.1.10: Betroffen
    • 1.1.11: Betroffen
    • 2.0.0: Betroffen
    • 2.0.1: Betroffen
    • 3.0: Betroffen
    • 4.0: Betroffen
    • 1.1.12: Nicht betroffen
    • 2.0.2: Nicht betroffen
    • 3.0.1: Nicht betroffen
    • 4.0.1: Nicht betroffen

    Auf 1.1.12 aktualisieren; Auf 2.0.2 aktualisieren; Auf 3.0.1 aktualisieren; Auf 4.0.1 aktualisieren

  • node-brace-expansion Debian:12

    Softwareversionen
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.1+~1.1.0-2

    Auf 2.0.1+~1.1.0-2 aktualisieren

  • node-brace-expansion Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.1+~1.1.0-2

    Auf 2.0.1+~1.1.0-2 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.0.2

    Auf 2.0.2 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.0.0, < 1.1.12

    Auf 1.1.12 aktualisieren

  • brace-expansion npm

    Softwareversionen
    • 3.0.0
    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.0.1

    Auf 3.0.1 aktualisieren

  • brace-expansion npm

    Softwareversionen
    • 4.0.0
    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.0.1

    Auf 4.0.1 aktualisieren

  • node-brace-expansion Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.8-1
    • 1.1.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0-1
    • 2.0.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:24.04:LTS

    Softwareversionen
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:25.10

    Softwareversionen
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →