CVE-2025-5889
CVE-2025-5889 · juliangruber brace-expansion index.js expand redos
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
CVSS 2.3 · Low · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
brace-expansion
- Versions
- 1.1.0: Affected
- 1.1.1: Affected
- 1.1.2: Affected
- 1.1.3: Affected
- 1.1.4: Affected
- 1.1.5: Affected
- 1.1.6: Affected
- 1.1.7: Affected
- 1.1.8: Affected
- 1.1.9: Affected
- 1.1.10: Affected
- 1.1.11: Affected
- 2.0.0: Affected
- 2.0.1: Affected
- 3.0: Affected
- 4.0: Affected
- 1.1.12: Not affected
- 2.0.2: Not affected
- 3.0.1: Not affected
- 4.0.1: Not affected
Update to 1.1.12; Update to 2.0.2; Update to 3.0.1; Update to 4.0.1
node-brace-expansion Debian:12
- Versions
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.1+~1.1.0-2
Update to 2.0.1+~1.1.0-2
node-brace-expansion Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.1+~1.1.0-2
Update to 2.0.1+~1.1.0-2
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.0.2
Update to 2.0.2
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 1.0.0, < 1.1.12
Update to 1.1.12
brace-expansion npm
- Versions
- 3.0.0
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.0.1
Update to 3.0.1
brace-expansion npm
- Versions
- 4.0.0
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.0.1
Update to 4.0.1
node-brace-expansion Ubuntu:18.04:LTS
- Versions
- 1.1.8-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:20.04:LTS
- Versions
- 1.1.8-1
- 1.1.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:22.04:LTS
- Versions
- 2.0.0-1
- 2.0.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:24.04:LTS
- Versions
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:25.10
- Versions
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://vuldb.com/?id.311660
- https://vuldb.com/?ctiid.311660
- https://vuldb.com/?submit.585717
- https://gist.github.com/mmmsssttt404/37a40ce7d6e5ca604858fe30814d9466
- https://github.com/juliangruber/brace-expansion/pull/65/commits/a5b98a4f30d7813266b221435e1eaaf25a1b0ac5
- https://github.com/juliangruber/brace-expansion/releases/tag/v4.0.1
- https://nvd.nist.gov/vuln/detail/CVE-2025-5889