p PatchFirst

CVE-2025-59471

CVE-2025-59471

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain. Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.

CVSS 5.9 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next

    Versiones
    • ≥ 10.0, < 10.0: Afectada (semver)
    • ≥ 11.0, < 11.0: Afectada (semver)
    • ≥ 12.0, < 12.0: Afectada (semver)
    • ≥ 13.0, < 13.0: Afectada (semver)
    • ≥ 14.0, < 14.0: Afectada (semver)
    • ≥ 15.0, < 15.5.10: Afectada (semver)
    • ≥ 16.0, < 16.1.5: Afectada (semver)

    Actualiza a 15.5.10; Actualiza a 16.1.5

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 10.0.0, < 15.5.10

    Actualiza a 15.5.10

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 15.6.0-canary.0, < 16.1.5

    Actualiza a 16.1.5

Fuentes originales

Comprueba tu servidor →