CVE-2025-59471
CVE-2025-59471
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain. Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
CVSS 5.9 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
next
- Versions du logiciel
- ≥ 10.0, < 10.0: Concernée (semver)
- ≥ 11.0, < 11.0: Concernée (semver)
- ≥ 12.0, < 12.0: Concernée (semver)
- ≥ 13.0, < 13.0: Concernée (semver)
- ≥ 14.0, < 14.0: Concernée (semver)
- ≥ 15.0, < 15.5.10: Concernée (semver)
- ≥ 16.0, < 16.1.5: Concernée (semver)
Mettez à jour vers 15.5.10; Mettez à jour vers 16.1.5
next npm
- Plages de versions concernées
- SEMVER: ≥ 10.0.0, < 15.5.10
Mettez à jour vers 15.5.10
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.6.0-canary.0, < 16.1.5
Mettez à jour vers 16.1.5