p PatchFirst

CVE-2025-59471

CVE-2025-59471

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain. Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.

CVSS 5.9 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next

    Softwareversionen
    • ≥ 10.0, < 10.0: Betroffen (semver)
    • ≥ 11.0, < 11.0: Betroffen (semver)
    • ≥ 12.0, < 12.0: Betroffen (semver)
    • ≥ 13.0, < 13.0: Betroffen (semver)
    • ≥ 14.0, < 14.0: Betroffen (semver)
    • ≥ 15.0, < 15.5.10: Betroffen (semver)
    • ≥ 16.0, < 16.1.5: Betroffen (semver)

    Auf 15.5.10 aktualisieren; Auf 16.1.5 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 10.0.0, < 15.5.10

    Auf 15.5.10 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 15.6.0-canary.0, < 16.1.5

    Auf 16.1.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →