p PatchFirst

CVE-2025-71404

CVE-2025-71404 · better-auth before 1.1.16 Reflected XSS via error parameter

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

CVSS 5.1 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • better-auth

    Versiones
    • ≥ 0, < 1.1.16: Afectada (semver)
    • 1.1.16: No afectada (semver)

    Actualiza a 1.1.16

  • better-auth npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.0.2, < 1.1.16

    Actualiza a 1.1.16

Fuentes originales

Comprueba tu servidor →