p PatchFirst

CVE-2025-71404

CVE-2025-71404 · better-auth before 1.1.16 Reflected XSS via error parameter

This page contains facts from public vulnerability sources. Check the original advisory before updating.

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

CVSS 5.1 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • better-auth

    Versions
    • ≥ 0, < 1.1.16: Affected (semver)
    • 1.1.16: Not affected (semver)

    Update to 1.1.16

  • better-auth npm

    Affected ranges
    • SEMVER: ≥ 0.0.2, < 1.1.16

    Update to 1.1.16

Original sources

Check your server →