p PatchFirst

CVE-2025-71404

CVE-2025-71404 · better-auth before 1.1.16 Reflected XSS via error parameter

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

CVSS 5.1 · Moyenne · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • better-auth

    Versions du logiciel
    • ≥ 0, < 1.1.16: Concernée (semver)
    • 1.1.16: Non concernée (semver)

    Mettez à jour vers 1.1.16

  • better-auth npm

    Plages de versions concernées
    • SEMVER: ≥ 0.0.2, < 1.1.16

    Mettez à jour vers 1.1.16

Sources originales

Vérifiez votre serveur →